[Qgis-developer] Problem in Compiling Source Code of Qgis in Ubuntu 12.04 LTS

Pedro Venâncio pedrongvenancio at yahoo.com
Sat Jan 25 08:00:31 PST 2014

Hi Richard,

Thank you very much for the hint! In my case I only have one version, libspatialindex-dev 1.7.0-1 (and libspatialindex1), the problem is that libspatialindex.so is in /usr/lib/libspatialindex.so and not in /usr/lib/i386-linux-gnu/libspatialindex.so. So I created a symlink and it worked!

But now bumped into the problem already pointed out by Paolo a few days ago:


Best regards,

> Hi Pedro,
> I'm on Debian testing, but I had exactly the same error:
> No rule to make target `/usr/lib/i386-linux-gnu/libspatialindex.so',
> needed by `output/lib/libqgis_core.so.2.1.0'.
> Something changed in the place/naming of libspatialindex
> What helped in my case: have a look if you maybe have several
> libspatialindex versions installed (in my case I had 2 version of the
> dev files of it).
> Then remove your build dir and start with a new build configuration:
> That fixed it with me.
> Regards,
> Richard

More information about the Qgis-developer mailing list