[Qgis-developer] C++ plugin setMapTool access violations

Hartmut Tschauner hartmut.tschauner at gmail.com
Wed Mar 5 04:47:13 PST 2014

Dear all,

Since I upgraded my C++ plugin code from 1.8 to 2.x and started building
against the 2.01 and 2.2 release code, the plugin has been experiencing
access violations when switching from my plugin's to any of the built-in
map tools (0xC0000005, "The thread tried to read from or write to a virtual
address for which it does not have the appropriate access.").  All it takes
to trigger a crash is to enable any of my map tools, then click on any QGIS
map tool--boom. This happens only when I run the plugin with the official
standalone or OSGeo4W binaries on Windows. It will **not** happen when the
plugin runs in my own QGIS binaries built from the 2.2 (or any other 2.x)
release code in Visual Studio 2008. The access violation occurs somewhere
deep in QGIS and I cannot debug it because it won't happen in my own build.

Have there been any changes since 1.8 that may explain these crashes and
that I may have missed? I would be most grateful for any suggestions or
leads that might help me get to the bottom of this crippling issue.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/qgis-developer/attachments/20140305/97404363/attachment.html>

More information about the Qgis-developer mailing list