[Qgis-developer] My God: plugin palette disappeared :(

Alex Mandel tech_dev at wildintellect.com
Fri Mar 7 10:52:42 PST 2014

On 03/07/2014 09:54 AM, Larry Shaffer wrote:
> Hi Jeff,
> Apologies for jumping into your conversation with Tim, but that issue with
> 1.8 was fixed before the 2.0 release [0]. I recommend, if possible, finding
> a means of your students running 2.0.1 or 2.2.0, where a user can now just
> select the items under the View menu. There are a couple workarounds for
> 1.8 listed on the issue page, however.
> If it is some dialog disappearing in the main app, that is probably a
> separate issue.
> [0] http://hub.qgis.org/issues/6125
> Regards,
> Larry
> On Fri, Mar 7, 2014 at 6:24 AM, Jeff McKenna
> <jmckenna at gatewaygeomatics.com>wrote:
>> On 2014-03-07, 9:07 AM, Tim Sutton wrote:
>>> What is a plugin palette? Do you mean the toolbar?
>>> Can you provide a screenshot of your running QGIS.
>>> Have you tried right clicking on the blank space in the toolbar area and
>>> checking if it is enabled.
>>> Did you maybe accidentally drag it and drop it somewhere and it is
>>> displaying in compressed mode?
>>> I'm not sure if your life will be any better in Arc* :-P
>> Hi Tim,
>> You mention something that awoke me here ha.  I teach intro to GIS at a
>> local college this term, and of course I am using QGIS (1.8, yes I know
>> old, but I am lucky to have anything installed in their locked down
>> environment).  The one problem that the students face constantly, and
>> the one problem I cannot solve, yet, is when they do something like you
>> just mentioned: they drag and drop a dialog somewhere, close it, undock
>> it, or I'm not sure what they are doing exactly...and then anytime they
>> start GIS on that same machine that dialog is no where to be found (and
>> for the life of me I cannot find how to turn it back on for them).  I
>> have struggled all term with this.  One example are the Properties
>> dialog windows in the Print Composer - students do something it seems to
>> close these, and they can never be seen ever again.
>> I know, maybe this is solved in QGIS 2.2, but I just wanted to give you
>> this feedback.  I love QGIS, but this one thing keeps coming back to
>> bite me in the butt.  Ha.
>> Talk soon my friend,
>> -jeff

This problem is some ways exists in both Arc and QGIS. Students make a
toolbar disappear and can't seem to get it back. Sometimes you just need
to re-enable it in the View->Toolbars

But often what you need to do is reset the GUI back to defaults which
can be done by clearing out the QGIS.conf file. Note doing this will
also destroy stored databases links and web service urls. Good news is
that you can save out those parts of the text and add them back in.

Where to find the QGIS.conf file varies by OS and install method.


More information about the Qgis-developer mailing list