[Qgis-developer] QGIS deb uninstallable?

Paolo Cavallini cavallini at faunalia.it
Mon Jan 4 00:29:53 PST 2016


Il 29/12/2015 22:06, J├╝rgen E. Fischer ha scritto:
> Hi Paolo,
> 
> On Tue, 29. Dec 2015 at 20:25:55 +0100, Paolo Cavallini wrote:
>> Thanks for the reply. I'm aware of this, that's why I used nightly both
>> for LTR and 2.13, but had no luck. Currently nightly-ltr wants to
>> install 2.8.2.
> 
> I guess you are using a distribution that has GRASS 7.  2.8 doesn't support the
> plugin with GRASS7.

Hi Juergen,
I still have the issue, with
deb http://qgis.org/debian-nightly-ltr sid main [0]
deb http://qgis.org/debian-nightly sid main [1]

Am I the only one?
All the best.

[0]
aptitude install qgis-plugin-grass
The following NEW packages will be installed:
  libqgis-core2.8.2{ab} libqgis-gui2.8.2{ab} libqgisgrass2.8.2{ab}
qgis-plugin-grass{b}
  qgis-plugin-grass-common{a}
0 packages upgraded, 5 newly installed, 0 to remove and 41 not upgraded.
Need to get 39.4 MB of archives. After unpacking 172 MB will be used.
The following packages have unmet dependencies:
 qgis-provider-grass : Breaks: qgis-plugin-grass (< 1:2.8.4) but
1:2.8.2+git20150725+d110452+99unstable is to be installed.
 qgis-plugin-grass : Depends: qgis (=
1:2.8.2+git20150725+d110452+99unstable) but
1:2.8.5+git20151227+4c3cf64+99unstable is installed.
                     Depends: libgdal1h (>= 1.8.0) but it is not
installable.
                     Depends: libgeos-c1 (>= 3.4.2) but it is not
installable.
                     Depends: libqscintilla2-12 (>= 2.8.4) but it is not
installable.
                     Depends: libspatialindex4 (>= 1.8.1) but it is not
installable.
 libqgisgrass2.8.2 : Depends: libgdal1h (>= 1.8.0) but it is not
installable.
                     Depends: libgeos-c1 (>= 3.4.2) but it is not
installable.
                     Depends: libqscintilla2-12 (>= 2.8.4) but it is not
installable.
                     Depends: libspatialindex4 (>= 1.8.1) but it is not
installable.
 libqgis-gui2.8.2 : Depends: libgdal1h (>= 1.8.0) but it is not installable.
                    Depends: libgeos-c1 (>= 3.4.2) but it is not
installable.
                    Depends: libqscintilla2-12 (>= 2.8.4) but it is not
installable.
                    Depends: libspatialindex4 (>= 1.8.1) but it is not
installable.
 libqgis-core2.8.2 : Depends: libgdal1h (>= 1.8.0) but it is not
installable.
                     Depends: libgeos-c1 (>= 3.4.2) but it is not
installable.
                     Depends: libqscintilla2-12 (>= 2.8.4) but it is not
installable.
                     Depends: libspatialindex4 (>= 1.8.5) but it is not
installable.


[1]
 python-qgis : Depends: liblwgeom-2.1.8 but it is not installable.
(in fact. liblwgeom-2.2-2 is available)
-- 
Paolo Cavallini - www.faunalia.eu
QGIS & PostGIS courses: http://www.faunalia.eu/training.html


More information about the Qgis-developer mailing list