[Tilecache] Transparent backgrounds are black in Google Maps

Roger André randre at gmail.com
Wed Sep 24 16:48:23 EDT 2008

Thanks Chris,

I tried that, and it doesn't work.  So I reinvestigated what happens when I
make WMS requests manually and found that regardless of how I structure the
request, I still get black output.  The only way in which I get transparency
is when I use Mapserver in "mode=map".  So I think I'm back to debugging my
Mapserver configuration.


On Wed, Sep 24, 2008 at 12:44 PM, Christopher Schmidt <
crschmidt at metacarta.com> wrote:

> On Wed, Sep 24, 2008 at 12:43:19PM -0700, Roger André wrote:
> > Ok, so I think this might actually be a Tilecache issue, though I'm sure
> it
> > can be resolved via configuration.  I took a look in the cache, and the
> > tiles there don't have the background set to transparent.  However, when
> I
> > make a WMS request directly, the tiles are returned with alpha correctly
> > inside of them.
> >
> > I've read that this is because Tilecache doesn't correctly forward the
> > "Transparent=true" request to the WMS service.  Is that true?
> TileCache does not pass through any options from the request through to
> the WMS service.
> Assuming your'e using a WMS layer type, put ?transparent=true at the end
> of your URL. (Or, if you already have a  "?" in your URL,
> "&transparent=true".)
> Regards,
> --
> Christopher Schmidt
> MetaCarta
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osgeo.org/pipermail/tilecache/attachments/20080924/eec9f03c/attachment.html

More information about the Tilecache mailing list