[gdal-dev] GDAL 1.5.2 RC3 and HDF

Andrew Brooks arb at sat.dundee.ac.uk
Fri May 30 14:26:27 EDT 2008

On Fri, 30 May 2008 18:30:43 +0100, Even Rouault <even.rouault at mines-paris.org> wrote:
> There is already a GDAL ticket for this issue :
> http://trac.osgeo.org/gdal/ticket/2297

Thanks for pointing that out.  But it's 2 months old and hdf5-1.8 isn't going
away ;-)  I recommend gdal-1.5.3 simply defines something before including the
hdf5 headers, something like H5_USE_16_API, then it will compile with both old
and new hdf5.  But the author should check that's an appropriate setting (I just
found it by looking through H5version.h, not by reading the manual ;-))


More information about the gdal-dev mailing list