[gdal-dev] gdal 1.5.3 dependencies on Linux

Gong, Shawn (Contractor) Shawn.Gong at drdc-rddc.gc.ca
Mon Nov 24 09:47:04 EST 2008

hi list,

I am building gdal 1.5.3 on Linux (RHEL).
I build the dependencies as follows (this was what I used for gdal

1) glib 1.2.10
2) gtk+ 1.2.10           # stay with gtk 1.3 now, I plan to upgrade to
gtk 2 in near future

3) Mesa 5.0.2 (Mesalib only, no demo, no glut)
4) gtkglarea-1.2.2
5) python 2.5.2

6) pygtk-0.6.12
7) gtk+extra-0.99.17
8) python-gtkextra-0.22    # 6), 7) 8) are for gtk 1.3 

10) proj-4.4.7
11) gdal external format libraries
 11a) zlib-1.2.3
 11b) jpeg-6b
 11c) szip-2.1
 11d) HDF5
 11e) HDF4
12) gdal-1.5.3 (w/ rsat2 driver from 1.6 beta)

Would someone confirm that the above dependencies are right?

another question about gcc, I have been using
/usr/lib/libstdc++.so.5.0.3, is it too old for gdal-1.5.3?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osgeo.org/pipermail/gdal-dev/attachments/20081124/5b109b5d/attachment-0001.html

More information about the gdal-dev mailing list