[gdal-dev] GDAL scripting with Python 2.5 (on windows)

Frank Warmerdam warmerdam at pobox.com
Wed Oct 21 13:56:31 EDT 2009

Ivan wrote:
> Aleksey,
>>  Thank you, this works. I must have overlooked the gdal-python bindings
>>  package in the Advanced settings on my last try.
> Welcome.
>>  One thing I am currently missing in OSGeo4W GDAL is support for ECW and
>>  MrSID -- is it available? I've installed the gdal-ecw and gdal-mrsid
>>  packages, but it seems I am missing the DLLs. E.g. when I try "gdalinfo
>>  --formats" I get complaints:
>>  ERROR 1: Can't load requested DLL:
>>  C:\OSGeo4W\apps\gdal-16\bin\gdalplugins\gdal_ECW_JP2ECW.dll
>>  126: The specified module could not be found.
>>  ERROR 1: Can't load requested DLL:
>>  C:\OSGeo4W\apps\gdal-16\bin\gdalplugins\gdal_MrSID.dll
>>  126: The specified module could not be found.
>>  Have tried this with both gdal-* and gdal16-* packages. And remembered to
>>  run gdal16.bat to activate the GDAL 1.6 environment. However, can't get
>>  ECW and MrSID support.
>>  I suspect this is due to licensing issues. Do I need to install support
>>  for these formats separately?
> Yes, you need to get the SDKs from Erdas and Lizartech.
> See the GDAL supported format list for information: 
> http://www.gdal.org/formats_list.html


I would add that the OSGeo4W package pages for these packages have
additional details:


Best regards,
I set the clouds in motion - turn up   | Frank Warmerdam, warmerdam at pobox.com
light and sound - activate the windows | http://pobox.com/~warmerdam
and watch the world go round - Rush    | Geospatial Programmer for Rent

More information about the gdal-dev mailing list