[Live-demo] Re: minor ossim install script error

Hamish hamish_b at yahoo.com
Sun Feb 20 01:48:32 EST 2011

Hamish wrote:
> wget http://ossim.telascience.org/ossimdata/Documentation/OSSIM_Whitepaper.pdf
> this fails as ossim.telascience.org no longer exists.

Brian supplied the pdf from the last build, and I've
uploaded that (along with some new fyi OMAR pdfs) to
and uploaded the install script to match the new
home of the white paper pdf.

those pdfs should really be in 
but I'll let the ossim -devs take care of that.

in looking at the ossim-1.8.6 install script I
noticed a few other things, fixed some of them, and
commented on the rest:

#FIXME: Please do not use "chmod 777". Add to the "users" group and chmod g+w instead.

#apt-get --force was used. Is there a bloody good
reason for needing that? It could break the disc.

#FIXME: do not checkout directly to $USER_HOME. Use "svn export" to /usr/local/share/data/
  instead, or svn co to /tmp/build_ossim/ then copy dir to /usr/local/share/data/ and symlink into $HOME as needed.

#FIXME: Do not use chmod 777. see above.

#FIXME: python install fails. does the python-sphinx package need to be installed first?

#FIXME: wget -N is not compatible with -O. (no-op)

#FIXME: Another set of "Do not use chmod 777".

and why both install_ossim.sh (ver 1.8.3, unused)
and install_ossim-1.8.6.sh (used)? can we get rid
of the old one and rename the new one?

'svn co' directly into $USER_HOME/ is the worst
of those problems (wastes disc and RAM space).


ps- Massimo (or any other Italiano) if you have a
couple minutes could you have a look at the Italian
main index.html page translation? right now it
doesn't exist which totally breaks that locale.
see  http://adhoc.osgeo.osuosl.org/livedvd/docs/


More information about the Live-demo mailing list