[mapguide-users] Re: FDO PostGIS provider. Was: OGR Provider

Mateusz Loskot mateusz at loskot.net
Thu Jun 14 08:45:05 EDT 2007


Sorry I did not posted the update yesterday, my Internet
link was out of order.
Here is are new binaries:


Looking forward your feedback...


Jason Birch wrote:
> The current build is somewhat transitory, meaning I'm not sure what
> features are in it.  I'm expecting Mateusz to post a new build sometime
> in the next day that is a bit more feature-complete.
> A couple things to be aware of:
> - It requires the MSVC++ SP1 Redistributable to be installed on your
> computer (for Map) or the server (for MapGuide):
> <http://www.microsoft.com/downloads/details.aspx?familyid=200B2FD9-AE1A-
> 4A14-984D-389C36F85647&displaylang=en>
> - The PostgreSQL bin directory either needs to be in the path before any
> other version of libpq.dll and any of its dependancies (the ssl stuff
> was a problem for me) or the files from bin need to be copied into the
> FDO directory (bit of a hack to say the least).  For MapGuide, this
> needs to be the System path, not the user path, because the server runs
> as local service.
> You could also download and compile the most recent version yourself
> from SVN :)
> http://svn.osgeo.org/fdo/trunk/Providers/PostGIS/
> I haven't tried this yet myself.
> Jason 
> -----Original Message-----
> From: Jose Manuel C G
> Subject: [mapguide-users] RE: RE: OGR Provider
> I've tried the alpha version (
> http://mateusz.loskot.net/tmp/fdopostgis/?M=D
> here ) of PostGIS provider on Map 2008, without any success. The problem
> is the fdo of Map 2008, I think, because in the database connection,
> show the PostGIS provider, but in the right panel, a warning show an
> error with the FDO.

Mateusz Loskot

More information about the mapguide-users mailing list