[mapguide-users] Raster (SID / TIF ) Images not working !

BillMasters bwmasters at agri.ns.ca
Wed Sep 5 10:12:36 EDT 2007

Hello, I am fairly new to MGOS, and I am having problems getting raster
images to work.  I am using version 1.1. I installed all the dlls from

Note that in my development environment we have MG Enterprise setup and the
rasters worked fine. 

I have both sid and tif versions of the raster images I want to use, I have
tried both with the same result. They just do not display. Everything else
works. I have 2 raster layers setup, with differing quality images, I have
set them up so one uses SID,and one references the actual tif files. Below
is a excerpt of the debugging. A few errors in there. I know there was a
previous post referencing the Can't find RasterDMS field / IReadBlock failed
error, but the solution in this previous post was to change the GDAL13.DLL.
This should be changed in my setup (version is dated Jan 28, 2007). 

Any Ideas ?? 

---Excerpt from DEBUG----------------------------------------

GDAL: GDALClose(Y:\10KOrthos_2003\Mosaic\/bermuda2003.sid)

GDAL: GDALClose(Y:\10KOrthos_2003\Mosaic\/bermuda2003.aux)

---BUNCH OF THESE TYPE CALLS---------------------------------------------
GDAL: GDALOpen(Y:\10KOrthos_2003\10KOrthos_2003b/10k3929_2003.tfw) called.
GDAL: Now trying ECW driver.
ECW: OpenECW(Y:\10KOrthos_2003\10KOrthos_2003b/10k3929_2003.tfw)
GDAL: GDALOpen(Y:\10KOrthos_2003\10KOrthos_2003b/10k3929_2003.tif) called.
GDAL: Now trying ECW driver.
ECW: OpenECW(Y:\10KOrthos_2003\10KOrthos_2003b/10k3929_2003.tif)
GDAL: GDALOpen(Y:\10KOrthos_2003\10KOrthos_2003b/10k3929_2003.tif) succeeds
as G

(832|2152) Cannot establish connection.
Exception occurred in method MgFdoConnectionManager.Open at line 820 in file

---Bunch of these----------------------------
MrSID: Opened zoom level 8 with size 489x333.

MrSID: Opened zoom level 9 with size 245x167.

MrSID: Opened zoom level 0 with size 125000x85000.


MrSID: Opened image: width 125000, height 85000, bands 3
GDAL: GDALOpen(Y:\10KOrthos_2003\Mosaic\/bermuda2003.sid) succeeds as MrSID.

ERROR 1: Can't find RasterDMS field in Eimg_Layer with block list.

ERROR 1: IReadBlock failed at X offset 193, Y offset 204

View this message in context: http://www.nabble.com/Raster-%28SID---TIF-%29-Images-not-working-%21-tf4384333s16610.html#a12498848
Sent from the MapGuide Users mailing list archive at Nabble.com.

More information about the mapguide-users mailing list