[mapguide-users] Unable to connect to MGOS via MapGuide Studio/.NET API

Praveen Rajendra Babu prbabu at openspatial.com.au
Fri Mar 13 21:14:25 EDT 2009

    If I leave the MGOS server (version idle for a while(like overnight) and then try to connect to server via Maestro, I get the message.
************************* Maestro pop-up window message ****************************
Failed to log on because: Failed to connect, please check network connection and login information.
Extended error info: Failed to connect, perhaps session is expired?
Extended error info: Invalid server token recieved: <html><head><META http-equiv="Content-Type" content="text/html; charset=UTF-8"><title>osenlighten - /mapguide/</title></head><body><H1>osenlighten - /mapguide/</H1><hr>

<pre><A HREF="/">[To Parent Directory]</A><br><br>    Monday, December 22, 2008  3:25 PM        &lt;dir&gt; <A HREF="/mapguide/data/">data</A><br>    Monday, December 22, 2008  3:32 PM        &lt;dir&gt; <A HREF="/mapguide/dotnetviewersample/">dotnetviewersample</A><br>    Tuesday, January 20, 2009 12:02 PM        &lt;dir&gt; <A HREF="/mapguide/fusion/">fusion</A><br>    Tuesday, January 20, 2009 11:54 AM      1847872 <A HREF="/mapguide/fusion-1.1.0.zip">fusion-1.1.0.zip</A><br>   Thursday, January 08, 2009  9:46 AM        &lt;dir&gt; <A HREF="/mapguide/fusion-old/">fusion-old</A><br>    Monday, December 22, 2008  3:25 PM        &lt;dir&gt; <A HREF="/mapguide/localized/">localized</A><br>    Monday, December 22, 2008  3:25 PM        &lt;dir&gt; <A HREF="/mapguide/mapadmin/">mapadmin</A><br>    Monday, December 22, 2008  3:25 PM        &lt;dir&gt; <A HREF="/mapguide/mapagent/">mapagent</A><br>  Wednesday, January 21, 2009  6:08 PM        &lt;dir&gt; <A HREF="/mapguide/mapviewernet/">mapviewernet</A><br>   Tuesday, December 23, 2008 12:24 PM        &lt;dir&gt; <A HREF="/mapguide/mapviewerphp/">mapviewerphp</A><br>    Monday, December 22, 2008  3:25 PM        &lt;dir&gt; <A HREF="/mapguide/nad/">nad</A><br>     Friday, January 30, 2009  2:31 PM        &lt;dir&gt; <A HREF="/mapguide/OpenLayers-2.7/">OpenLayers-2.7</A><br>     Friday, January 30, 2009  1:52 PM        &lt;dir&gt; <A HREF="/mapguide/phpviewersample/">phpviewersample</A><br>    Monday, December 22, 2008  3:25 PM        &lt;dir&gt; <A HREF="/mapguide/schemareport/">schemareport</A><br>    Monday, December 22, 2008  3:25 PM        &lt;dir&gt; <A HREF="/mapguide/stdicons/">stdicons</A><br>    Monday, December 22, 2008  3:25 PM        &lt;dir&gt; <A HREF="/mapguide/viewerfiles/">viewerfiles</A><br>    Monday, December 22, 2008  3:27 PM         8245 <A HREF="/mapguide/webconfig.ini">webconfig.ini</A><br>    Monday, December 22, 2008  3:25 PM        &lt;dir&gt; <A HREF="/mapguide/webstudio/">webstudio</A><br></pre><hr></body></html>
************************* Maestro pop-up window message ****************************

If I try to connect to the MGOS server via .NET API code, I get the below message:
<meta http-equiv="Content-type" content="text/html; charset=utf-8">
<h2>Cannot establish connection.</h2>
Cannot establish connection.
Exception occurred in method MgServerConnection.Open at line 106 in file d:\buildforgeprojects\carrera_nightly\build_32.2\ent\os\common\mapguidecommon\Services/ServerConnection.cpp


   To get things back to normal, I re-start WWW services in Windows Server 2003. Am I missing something in the set-up or configuration of MGOS or IIS Server?  FYKI, we are using IIS Server v6.0.

Any comments/suggestions would be highly appreciated.

Thanks and regards,

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osgeo.org/pipermail/mapguide-users/attachments/20090314/fbb7310a/attachment.html

More information about the mapguide-users mailing list