[mapserver-dev] Single-pass query RFC updated...
dmorissette at mapgears.com
Mon Jun 8 13:27:41 EDT 2009
Steve Lime wrote:
> I had thought about that. I think that will break more apps since most folks only use msLayerGetShape() in
> the context of queries. Which is worse? I do like the more explicit name of msLayerResultSetGetShape().
Good point. However the apps that currently call GetShape in the context
of queries will need to be fixed to avoid calling open/close anyway, so
the change to use msLayerResultSetGetShape is just one more tiny change
for apps that will already be broken and require an update.
In a context where both approaches have side-effects, perhaps the better
name could be the reason to choose one over the other?
> Note that for many drivers the msLayerResultSetGetShape() would just wrap msLayerGetShape() since
> the result set indexes reference the main dataset. Shapefiles would work like this. Any driver that didn't/couldn't
> maintain a result set handle could do it this way and would work like do now.
That's what I thought we would do for OGR.
More information about the mapserver-dev