[mapserver-users] Query functions with Oracle Spatial

Smith, Michael ERDC-CRREL-NH michael.smith at usace.army.mil
Mon Apr 5 18:37:15 EDT 2010


What version of Mapserver are you using? I suspect a version before 5.4 ( I
think that is when it changed ). The SE_ANNO_CAD_DATA field is a BLOB and
not a supported return type for queries. You can either upgrade to a newer
version of Mapserver which excludes BLOB fields or you can write a view to
exclude that column and query the view.


Michael Smith
RSGIS Center
US Army Corps of Engineers


On 4/5/10 12:33 PM, "Daiane Azevedo de Fraga" <daiane.a.fraga at gmail.com>

> Hello!
> I tried to execute a query function through an interface. Appeared in the
> logfile: 
> [Mon Apr 05 11:09:19 2010] msOracleSpatialLayerGetShape .621000 ():
> OracleSpatial error. Error parsing OracleSpatial DATA is variable query. To
> execute query functions you need to define one unique column [USING UNIQUE <#
> column>] 
> I added the ID column, and now appears in the logfile:
> [Mon Apr 05 11:11:47 2010] .358000 msOracleSpatialLayerGetShape ():
> OracleSpatial error. Error: ORA-00932: inconsistent datatypes: expected %s
> returned %s. Query statement: SELECT ID, NBLOCK, SECTOR, BLOCK, ORIGIN, TYPE,
> SE_ANNO_CAD_DATA, SHAPE FROM LOTS WHERE ID = 43,192. Check your statement
> date.
> What can it be? It worked in some cases. The columns are apparently right...
> There may be some incompatibility factor?
> Thanks!
> --
> Daiane
> _______________________________________________
> mapserver-users mailing list
> mapserver-users at lists.osgeo.org
> http://lists.osgeo.org/mailman/listinfo/mapserver-users

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osgeo.org/pipermail/mapserver-users/attachments/20100405/74c79887/attachment.html

More information about the mapserver-users mailing list