[OpenLayers-Users] Firefox 6 gives more errors than other browsers

Mark K. Zanfardino mzanfardino at gmail.com
Wed Sep 21 17:56:13 EDT 2011

I have run into a similar problem. Since I upgraded FF to 6.0.2 I am 
finding that I can not load the OpenLayers API uncompressed.  When I 
make a reference to OpenLayers/lib/OpenLayers.js I find that my page 
fails to load and all references to OL returns an Undefined error in 
firebug console.  However, I can load the exact same page in IE or 
Chrome and everything works just fine.

If I switch to using the compressed OpenLayers.js file everything works 
just fine as well. I'm stepping through the OpenLayers.js file to see if 
I can find anything specific to FF, but not knowing what I'm looking for 
is making this extremely time consuming.  If anyone else has run into 
this issue, please post your comments here.

NOTE: I've tried this with OL 2.10 and 2.11 on IE8, IE9, Chrome, FF 3.6 
and FF 6.0.2. My map pages loads in all browsers listed except FF 6.0.2


On 08/30/2011 03:57 AM, Robert Buckley wrote:
> Hi,
> After installing FF6 I have found that the error console is more 
> active than before.
> Mostly the first load of an app is ok, and then by refreshing the 
> browser, an error comes, the second refresh gives even more errors. 
> This is consistant!
> Has anyone else found this?
> yours,
> Rob
> _______________________________________________
> Users mailing list
> Users at lists.osgeo.org
> http://lists.osgeo.org/mailman/listinfo/openlayers-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osgeo.org/pipermail/openlayers-users/attachments/20110921/087db139/attachment.html

More information about the Users mailing list