[postgis-users] Again: ERROR: function 60821C60 returned NULL

Obe, Regina robe.dnd at cityofboston.gov
Tue Aug 7 04:28:46 PDT 2007

Just to add to what Mark said.  I had this issue when switching over
from 8.1 to 8.2. It was a problem with the GEOS library interaction with
8.2 which I think was fixed with Geos 3.0.0rc4 and above (there might
have been a slightly lower version that fixed it.)

If you are running 8.2 with Geos 2.3 or something like that, then you
will get the below error you describe.  This problem did not occur with
Geos 2.3 and below against 8.1.



-----Original Message-----
From: postgis-users-bounces at postgis.refractions.net
[mailto:postgis-users-bounces at postgis.refractions.net] On Behalf Of Mark
Sent: Tuesday, August 07, 2007 4:23 AM
To: PostGIS Users Discussion
Subject: Re: [postgis-users] Again: ERROR: function 60821C60 returned

On Mon, 2007-08-06 at 13:09 -0400, Burgholzer,Robert wrote:
> I am experiencing an error that I have seen in the archives with the
> title: "ERROR: function 60821C60 returned NULL".  Any help would be
> appreciated.
> It seems that in the previous posts, a null geometry (or rather too
> many of them) was the cause. I, however, am experiencing it with NO
> NULL geoms, instead using points with lat/lon = 0.0.  That said, I
> have tried it several ways, one of which is with no nulls (usigng
> 0.0s), the others with the nulls.  All throw the error when trying to
> create a GIST index.
> My Data:
> creating points from DD lat/lon values, with the following:
> set the_geom = GeomFromText('POINT(' || "LAT_DEC" || ' ' || "LONG_DEC"
> || ')', 4326)
> where "LAT_DEC" is not null and "LAT_DEC" <> 0 and "LONG_DEC" is not
> null and "LONG_DEC" <> 0;
> Insuring that I have no null values with the following:
> update water_use_dd set the_geom = GeomFromText('POINT(0.0 0.0)',
> 4326) 
> where the_geom is null;
> My system:
> Output of postgis_version():
> PostgreSQL 8.2
> Windows XP

Hi Robert,

Can you confirm which version of PostGIS you are using (SELECT
postgis_full_version())? I tried the following on a PostgreSQL
8.1/PostGIS 1.1.6 installation here and it worked for me:

CREATE TABLE test AS SELECT MakePoint(random(), random()) AS the_geom
FROM generate_series(1, 10000);
UPDATE test SET the_geom = GeomFromText('POINT(0.0 0.0)', 4326) WHERE
the_geom IS NULL;
CREATE INDEX test_index ON test USING gist (the_geom);

Can you provide a complete SQL script similar to above that will
reproduce the error on your system?

Many thanks,


ILande - Open Source Consultancy

postgis-users mailing list
postgis-users at postgis.refractions.net

The substance of this message, including any attachments, may be
confidential, legally privileged and/or exempt from disclosure
pursuant to Massachusetts law. It is intended
solely for the addressee. If you received this in error, please
contact the sender and delete the material from any computer.

More information about the postgis-users mailing list