[postgis-users] can't run lwpostgis

Mark Cave-Ayland mark.cave-ayland at ilande.co.uk
Sun Aug 19 04:17:00 PDT 2007

On Sun, 2007-08-19 at 01:23 -0700, Ryan D. Enos wrote:
> Hi Everyone,
> I'm sure this is an easy answer, but it has me held up and I'd really 
> like to figure it out.
> I am recently running Windows Vista with postgresql 8.2, I am attempting 
> to upgrade to postgis 1.3.1.  As such, I have removed the earlier 
> version of postgis using the postgres installer.  I have run the postgis 
> 1.3.1 installer and am trying to do the 'softupgrade'. Here is the 
> problem, when I run the command from:
> C:\Program Files\PostgreSQL\8.2\share\contrib>psql -f 
> lwpostgis_upgrade.sql -d il_voter_1
> 'psql' is not recognized as an internal or external command, operable 
> program or batch file.
> When I run from:
> C:\Program Files\PostgreSQL\8.2\bin>psql -f lwpostgis_upgrade.sql -d 
> il_voter_1
> Password:
> lwpostgis_upgrade.sql: No such file or directory
> But the file is definitely there!  I have even tried to build it myself 
> using the suggestion from the documentation.
> So, I'm sure this is just something about the way I have postgresql 
> installed, but can anybody help me out on this.
> Thanks.
> Ryan

Hi Ryan,

If you look at the start menu, the PostgreSQL installers normally place
a "Command Prompt" option under the "PostgreSQL 8.2" group which
automatically sets the PATH to include C:\Program Files\PostgreSQL\8.2
\bin. I'd use this, and then go for your first option:

C:\Program Files\PostgreSQL\8.2\share\contrib>psql -f
lwpostgis_upgrade.sql -d il_voter_1



ILande - Open Source Consultancy

More information about the postgis-users mailing list