[postgis-users] install problems Postgis 1.4.0 with Postgres8.4.0 on Mac OS X 10.5

P Kishor punk.kish at gmail.com
Thu Aug 20 18:03:07 PDT 2009

On Thu, Aug 20, 2009 at 7:41 PM, Paragon Corporation<lr at pcorp.us> wrote:
> Ah okay that explains it.  Yes the new file should be called postgis-1.4.so
> and the script you should use in postgis.sql
> I guess your old scripts from your 8.3 were left behind.  You should delete
> them to minimize on confusion

Thanks Regina. I blew away the entire /usr/local/pgsql and started
from scratch. It all seems to be fine now. I was misled by the
abbreviated instructions write on top of the tin


see the sidebar... that refers to lwpostgis.sql instead of

Perhaps that should be corrected.

Many thanks,

> -----Original Message-----
> From: postgis-users-bounces at postgis.refractions.net
> [mailto:postgis-users-bounces at postgis.refractions.net] On Behalf Of P Kishor
> Sent: Thursday, August 20, 2009 8:25 PM
> To: postgis-users at postgis.refractions.net
> Subject: Re: [postgis-users] install problems Postgis 1.4.0 with
> Postgres8.4.0 on Mac OS X 10.5
> I should have mentioned, I installed 8.4.0/1.4.0 on an existing install of
> 8.3.7/1.3.x. Seems like the old liblwgeom.so not get replaced by a new one.
> Why not?
> On Thu, Aug 20, 2009 at 6:25 PM, P Kishor<punk.kish at gmail.com> wrote:
>> I did a pretty plain vanilla Postgres 8.4.0 and Postgis 1.4.0
>> installation on my Macbook, but am getting the following error when
>> trying to build my first db
>> Lucknow:~ postgres$ /usr/local/pgsql/bin/psql -d punkish -f
>> /usr/local/pgsql/share/lwpostgis.sql
>> psql:/usr/local/pgsql/share/lwpostgis.sql:44: NOTICE:  type
>> "histogram2d" is not yet defined
>> DETAIL:  Creating a shell type definition.
>> psql:/usr/local/pgsql/share/lwpostgis.sql:44: ERROR:  incompatible
>> library "/usr/local/pgsql/lib/liblwgeom.so": version mismatch
>> DETAIL:  Server is version 8.4, library is version 8.3.
>> psql:/usr/local/pgsql/share/lwpostgis.sql:50: ERROR:  current
>> transaction is aborted, commands ignored until end of transaction
>> block
>> How did I end up with a mismatch between the server and the
>> liblwgeom.so lib? And, most importantly, what do I do to correct this?
>> Many thanks in advance,
>> --
>> Puneet Kishor http://www.punkish.org
>> Carbon Model http://carbonmodel.org
>> Charter Member, Open Source Geospatial Foundation http://www.osgeo.org
>> Science Commons Fellow,
>> http://sciencecommons.org/about/whoweare/kishor
>> Nelson Institute, UW-Madison http://www.nelson.wisc.edu
>> ----------------------------------------------------------------------
>> - Assertions are politics; backing up assertions with evidence is
>> science
>> ======================================================================
>> =

More information about the postgis-users mailing list