[postgis-users] make install problem in v. 1.4.0 as well as in 1.4.1.SVN

Peter Sarkoci peter.sarkoci at gmail.com
Fri Oct 16 15:10:24 PDT 2009

Mark Cave-Ayland wrote:

>Peter Sarkoci wrote:
>> Hello everybody,
>> trying to make a slackbuild script for Slackware 13.0 I encountered a problem.
>> * Short description: "make install" does not copy the man pages into
>> the destination directory. This applies to postgis 1.4.0 as well as to
>> 1.4.1.SVN trunk.
>> * Long description: I do the following (step by step):
>> 1a) configure --prefix=/usr
>> which runs without any problem, just complaining it is not able to
>> find any XSL-template of the docbook system. Having on mind this could
>> be the reason why, later on, make gives up to do anything with man
>> pages I tried also
>> 1b) configure --prefix=/usr
>> --with-xsldir=/usr/share/xml/docbook/xsl-stylesheets-1.75.1
>> in which case configure runs without complaints.
>> 2) make
>> runs without any problem
>> 3) make install DESTDIR=/tmp/SBo/package-postgis
>> runs also without complaints, but in the end, there are no man pages
>> in the sub-directories of $(DESTDIR). Moreover, during both runs of
>> "make" the directory with documentation is _never_ entered.
>> * Now the question: is it my mistake, an intentional behavior or a
>> bug? It is not a big problem anyway, within the slackbuild script I
>> can fix the problem easily. On the other hand, it could turn out that
>> such a fix is not the kosher way to go.
>> Thanks
>> Peter
>Hi Peter,
>The short version of this is that I think due to changes being made at
>the time, it was felt that due to the large number of dependencies
>required for the documentation then it should remain a separate target.
>However, a manual "make install" in the docs/ directory should attempt
>to put things in the right place for you - if it doesn't, then please
>let us know.

Hello everybody, Hi Mark,

thank you very much for your explanation and suggestion. I tried it
and, well, running "make install" does not solve my problem in a
slackbuild-correct way. This is mainly due to the fact that the
makefile in the "doc" directory does not implement the, otherwise
common, variable DESTDIR. As a consequence, running configure with
--datarootdir=/usr prepares the makefile to install the manpages into
/usr/man and this regardless of the actual value of $(DESTDIR).
Unfortunately, this is fatal for the correct way of writing
slackbuilds; they first prepare the whole installation in a separate
location pointed to by $(DESTDIR) and just then they pack it into the
final package. Could it be considered a bug?

For the time being i decided to solve the problem semi-manually, not
relying on the invocation of "make install".

Thanks again,

More information about the postgis-users mailing list