[postgis-users] st_transform crashes

Bryan Hempen bryanhempen at gmx.de
Thu Jul 28 19:35:55 PDT 2011

Hi there!

I have a table containing unprojected footprints from observations on Mars, just polygons and multipolygons (no curved). For Mars, reference systems are defined by IAU2000 codes, similar to EPSG codes for earth data. 

This is the projection the data currently has:


...and I need it to be projected into this one: 


Therefore, I took the PostGIS insert statements on the respective pages, ingested them into the database and then tried to project the data using

select st_transform(geom_shifted, 949910) from alldata 

The result is that the database crashes with the message *** Error *** and I need to restart the PostgreSQL service in order to use it again. I have no clue why the database crashes. This is what I tried to far:

(1) set the srid to epsg 4326 just for testing and projections work fine, for example to 90093

(2) projected from IAU2000:49900 to some other common mars projections listed on http://spatialreference.org/ref/?search=mars . all of the projections worked except for the Equidistant Cylindrical ones (database crash as described), but those are exactly the ones I need!

(3) exported the data to a shapefile and tried to project it using ogr2ogr. command: 
ogr2ogr -f "ESRI Shapefile"  -s_srs "+proj=longlat +a=3396190 +b=3376200 +no_defs" -t_srs "+proj=eqc +lat_ts=0 +lat_0=0 +lon_0=0 +x_0=0 +y_0=0 +a=3396190 +b=3396190 +units=m +no_defs" "1.shp"  "2.shp" 
worked fine!

The proj4 definition I needed for the ogr2ogr command for IAU2000:49913 cannot be exported on spatialreference.org...Any clue why?

The 'custom', non-EPSG codes can't be the problem because of (1) and (2). Why would ogr2ogr do the job and PostGIS would not?

Is "+proj=eqc +lat_ts=0 +lat_0=0 +lon_0=0 +x_0=0 +y_0=0 +a=3396190 +b=3396190 +units=m +no_defs" even correct? I found that proj4 string in other data projected with an equidistant cylindrical projection. Is anyone able to translate that into a PostGIS insert statement?  

I was not able to find anything on problems with PostGIS and equidistant cylindrical projections...   

I uploaded a shapefile containing the data: http://www.file-upload.net/download-3621892/problem.zip.html

Thanks in advance!

Kind regards,

More information about the postgis-users mailing list