[Qgis-developer] Build dependency list
ivan.mincik at gmail.com
Sun Mar 21 06:44:49 EDT 2010
I would like to ask if the "An overview of the dependencies required
for building" provided by INSTALL file is still correct information.
'''Required build deps:'''
* CMake >= 2.4.3
* Flex, Bison
'''Required runtime deps:'''
* Qt >= 4.3.0
* Proj >= 4.4.x
* GEOS >= 3.0
* Sqlite3 >= 3.0.0
* GDAL/OGR >= 1.4.x
I am not sure about Qt and GDAL/OGR as well.
Is there any official long term plan about which minimal versions to
keep when coding (I remember some information about Qt 4.4) ? This
information is important for enterprise distributions like Debian, to
know if next version of Qgis will run without updating lot of core
Thanks a lot for Your work,
More information about the Qgis-developer