[El] rebuilding gdal

Jim Williams jwilliams108 at hotmail.com
Fri Dec 31 19:24:44 EST 2010

Hi Mathieu,

Thanks for the response,
> Can you please post more details about your errors? (logs, versions, etc.).

It is a configure error:
checking for libtiff... using libtiff from external.checking for TIFFScanlineSize64 in -ltiff... nochecking for XTIFFClientOpen in -lgeotiff... nochecking for XTIFFClientOpen in -lgeotiff... (cached) noconfigure: error: We require at least GeoTIFF 1.2.1. Consider using the one supplied with GDAL
Further investigation (by running mock shell) reveal that libgeotiff and none of the other BuildRequire dependencies have been installed, just the base environment.
> Are you trying to rebuild the stable or the testing repo?

I have tried stable as well as the latest 1.7.2 from testing, both with the same results. I have also tried the EL6 beta SRPM, also with the same result. This seems to indicate the problem is with my mock setup, but I can find no errors - mock simply is not installing the dependencies. And, as I mentioned, this mock setup has worked fine to this point with numerous other packages (as well as with the dependencies for gdal).
> We have been working a lot on GDAL recently so we may have introduced
> regressions...
I don't think this is the issue.
> But we also build in the CentOS 5.5 mock (with the EPEL repo enabled in
> the mock config files!)

I do not have EPEL enabled, but have rebuilt the dependencies locally. I am not particularly familiar with mock, beyond running the basic rebuild command. Is there a setting that would prevent dependencies from being installed?
Thanks again for your help,Jim 		 	   		  

More information about the el mailing list