[fdo-internals] automake/autoconf/libtool preferred version?

Frank Warmerdam warmerdam at pobox.com
Sat Feb 10 22:54:10 EST 2007


What version of automake/autoconf/libtool are being used successfully when
building FDO "trunk" on Linux?  I just tried building on my 64bit ubuntu
system and got some pretty funky issues.

The Fdo/Unmanaged/Src/Makefile includes this line:

libFDO.la: $(libFDO_la_OBJECTS) $(libFDO_la_DEPENDENCIES)
	$(LINK) -rpath $(libdir) $(libFDO_la_LDFLAGS) $(libFDO_la_OBJECTS) 
$(libFDO_la_LIBADD) $(LIBS)

But there is no definition of LINK in the Makefile, nor any apparently
definition so the command run start with the -rpath.

Oddly, even if I manually introduce LINK=ld in the file, I still get
a strange complaint about the rpath even though it looks fine.

I'm *assuming* this is some sort of automake, or perhaps libtool related
issue but I'm not exactly sure.  I will say I hate it when building from
source control always means having to run my own versions of automake, libtool
and autoconf as often there are surprising version dependencies.  But I do
accept that this is the common approach.

BTW, i'm running:

warmerda at amd64[85]% autoconf --version
autoconf (GNU Autoconf) 2.59

warmerda at amd64[86]% automake --version
automake (GNU automake) 1.4-p6

warmerda at amd64[87]% libtool --version
ltmain.sh (GNU libtool) 1.5.6 (1.1220.2.95 2004/04/11 05:50:42) Debian: 224 $

Best regards,
I set the clouds in motion - turn up   | Frank Warmerdam, warmerdam at pobox.com
light and sound - activate the windows | http://pobox.com/~warmerdam
and watch the world go round - Rush    | President OSGeo, http://osgeo.org

More information about the fdo-internals mailing list