[fdo-internals] RE: 64 bit boost compilation on 64 bit machine

Greg Boone greg.boone at autodesk.com
Fri Mar 12 10:09:42 EST 2010

I have seen this issue as well, building boost locally. For now, I advise doing a one-off build of all the Thirdparty components such as boost and only rebuilding them if there are changes in that sub-directory. In the meantime, I can try and grab a newer version of boost to see if that makes a difference, and try and research the issue.


From: fdo-internals-bounces at lists.osgeo.org [mailto:fdo-internals-bounces at lists.osgeo.org] On Behalf Of Trevor Wekel
Sent: Thursday, March 11, 2010 11:53 PM
To: FDO Internals Mail List
Subject: [fdo-internals] 64 bit boost compilation on 64 bit machine


I am trying to run a 64 bit build of Fdo on a 64 bit Windows Web Server 2008 box.  I seem to be getting hung up when building Thirdparty\boost.  It looks as though bjam starts to run but then it throws a Windows dialog box stating

Window's can't open this file:

I tried grabbing a newer version of bjam.exe but that did not seem to correct the problem.

Very weird.  The 32 bit build was successful.  Any ideas?  Has anyone else tried building 64 bit Fdo on a 64 bit machine?

"cl" returns "Microsoft (R) C/C++ Optimizing Compiler Version 15.00.30729.01 for x64" on my machine.  Not sure if that will make a difference or not.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osgeo.org/pipermail/fdo-internals/attachments/20100312/8728c9e6/attachment.html

More information about the fdo-internals mailing list