Re: [fdo-users] GDAL FDO provider with raster performance enhancements

robert fritz robert-fritz at
Fri Aug 24 07:45:23 EDT 2007


I have just installed MG OS 1.2.0RC2. I run the PHP script "rasterconfig.php" and it created the resource succesfully. In Studio the new data connection is available - but the FDO component throws an exception ("Failed to de-serialize...) when I try to create a layer on base of the connection.

But - I'm not sure if it had been mentioned as I downloaded the files the first time or if I ignored the notice - the new feature I'm interested in requires "FDO 3.2.3 and MapGuide 1.2 or greater". Neither MGE2008 nor MGOS 1.2RC2 use FDO3.2.3 - so I think that explains the failure,

Regards, Robert

*Von:* "robert fritz" <ROBERT-FRITZ at WEB.DE>
*Gesendet:* 23.08.07 16:25:57
*An:* FDO Users Mail List <FDO-USERS at LISTS.OSGEO.ORG>
*Betreff:* Re: [fdo-users] GDAL FDO provider with raster performance enhancements


thank you very much for your reply. In Studio I can create a new "Data Connection" using the GDAL provider listed in the "Select feature provider" dialog box. I put the path to the folder in the "Connection properties" (labeled as DefaultRasterFileLocation), "Test Connection" gives back a "Succesful connection". But I do not get a list of files when I click on "View data" in the "preview" pane. And I do not see any image in the layer or map preview - even if I combine the raster image layer with a sdf based "boundary" layer. The problem is - there isn't any error message - neither in Studio nor in the the server log files.

I'm not sure if I should install MG OS to test it - I think it should work with MGE 2008 too?

Regards, Robert

*Von:* FDO Users Mail List <FDO-USERS at LISTS.OSGEO.ORG>
*Gesendet:* 23.08.07 15:39:06
*An:* FDO Users Mail List <FDO-USERS at LISTS.OSGEO.ORG>
*Betreff:* Re: [fdo-users] GDAL FDO provider with raster performance enhancements

robert fritz wrote:
> Hi,
> I installed the new GDAL FDO provider with raster performance 
> enhancements ( on MGE 2008. 
> When I execute the configbuilder.php an "An exception occurred in FDO 
> component. FDO Provider Not Registered Exception occurred in method 
> MgFdoConnectionManager.Open at line 259 in file 
> c:uild_bond_areaBond_NightlyBUILD_41.3EntOSServersrcCommonManagerFdoConnectionManager.cpp 
> " occurs. It seems that the function $tmpSpatialContextReader = 
> $featureService->GetSpatialContexts($tmpResource, false); causes the 
> message.
> I have no idea what is going wrong. I tried different raster datasets 
> (tifs, png) but got the same error.


I'm not clear on why you would be getting as far as a GetSpatialContexts()
call before hitting a "provider not registered exception" but I don't
know how the configbuilder.php is setup. Does the provider work with
MGE for displaying raster data?

The first thing I would check is that the provider is properly listed
in the providers.xml file. I believe FDO is very sensitive to getting
version numbers right in this file for instance.

Best regards,
I set the clouds in motion - turn up | Frank Warmerdam, warmerdam at
light and sound - activate the windows |
and watch the world go round - Rush | President OSGeo,

fdo-users mailing list
fdo-users at

Erweitern Sie FreeMail zu einem noch leistungsstärkeren E-Mail-Postfach!	
Mehr Infos unter ** [] 
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the fdo-users mailing list