[fdo-users] Create an FdoFeatureClass?

Traian Stanev traian.stanev at autodesk.com
Tue Apr 14 15:32:55 EDT 2009

Did you try cloning the schema object and using ApplySchema with this new object? The provider could be returning a cached pointer to its internal schema, which you end up modifying. Later when you ApplySchema it cannot detect any changes to the schema since it's the same object. Cloning would work around that.


-----Original Message-----
From: fdo-users-bounces at lists.osgeo.org [mailto:fdo-users-bounces at lists.osgeo.org] On Behalf Of VJ
Sent: Tuesday, April 14, 2009 3:27 PM
To: fdo-users at lists.osgeo.org
Subject: RE: [fdo-users] Create an FdoFeatureClass?

That is my issue: it doesn't appear in PostGIS (no trace of it), I'm looking with pgadmin. :-(

>From in my program, everything seems in order (Schema contains class). But on the next execution, there also is no trace of it...

I tried flush (on the FdoIConnection), but to no avail.

Any thoughts?

If the subsequent FdoIDescribeSchema returns a FdoFeatureSchema containing your new class, then everything worked.

If you want to be doubly sure, take a look at the PostGIS database with pgAdmin and see if a new table (representing your new feature class) is there.

- Jackie

View this message in context: http://n2.nabble.com/Create-an-FdoFeatureClass--tp2611536p2634852.html
Sent from the FDO Users mailing list archive at Nabble.com.

fdo-users mailing list
fdo-users at lists.osgeo.org

More information about the fdo-users mailing list