[fdo-users] Connection problem SQL Server 2008 and FDO

LFELLI lofelli at tiscali.it
Sun Oct 4 13:04:02 EDT 2009

Hi to all,
I have just installed Windows server 2008, SQL Server 2008 Express, MapGuide
Open Source 2.0.2 and FDO 3.3.2
To configure the SQL Server 2008 i followed :
I downloaded SqlSpatialTools. With this tool i've uploaded a .shp file on
the Sql Server with Shape2Sql and previewed correctly with SqlSpatial tool
When i try to connect  SQL Server using MapGuide Maestro 1.0.9 (OSGeo FDO
Provider for SQL Server Spatial) i'm able to create the feature source, but
when i try to create a layer based on that feature source i receive the
following error:
 "Failed to read schema from data source.
The operation gave the error message: Bad document."

This is all my test:
I created a db called "navteq" with just one table called "dbo.isole"

-I change the table using only a column of type int (without any geometry or
geography type data) but nothing changed.

-I downloaded and installed FDO Toolbox. The connection is ok, but when i
expand the treeview i receive the following error:

Exception occurred: OSGeo.FDO.Common.Exception: Unable to find class 'S' at
OSGeo.FDO.Commands.Schema.IDescribeSchemaImp.Execute() at ....
The connection has a strange behavior, in fact if i collapse and then
reexpand the node of the table the error is slightly different each time,
for example:
"Exception occurred: OSGeo.FDO.Common.Exception: Unable to find class 'sole'
at ...
I attached a picture with another slightly different error.

Using DescribeSchema of mapagent (http://localhost:8008/mapguide/mapagent)
this is the empty result:
<?xml version="1.0" encoding="UTF-8" ?> 
  <fdo:DataStore xmlns:xs="http://www.w3.org/2001/XMLSchema" 
xmlns:fds="http://fdo.osgeo.org/schemas/fds" /> 

During installation progress of SqlServer 2008 Express i set "Mixed Mode"
for the "Authentication Mode".
I use "sa" user with the correct password for the connection, but i've also
tried to connect with windows authentication mode but the result is always
the same.

Am i missing something in the SQL Server configuration ?
Does FDO needs a particular configuration for SQL Server 2008 ?

P.S.I've also tried with FDO 3.4.0 and 3.4.1 with no result.

Any hints any will be appreciated.

View this message in context: http://n2.nabble.com/Connection-problem-SQL-Server-2008-and-FDO-tp3764539p3764539.html
Sent from the FDO Users mailing list archive at Nabble.com.

More information about the fdo-users mailing list