[fdo-users] FDO Compile error (libxalan-c)

Traian Stanev traian.stanev at autodesk.com
Fri Oct 9 17:33:02 EDT 2009

OK, so this must be an inconsistency between the automake and the cmake builds and you got the empty /usr/local/fdo directory created when you tried to run the automake build initially. The MapGuide docs are written with the FDO automake build in mind, since the cmake build was only recently added.

I don't know which one is more standard (/usr/local or /usr/local/lib), we should compare to what other libs do and standardize it, but yes, a quick solution would be to switch the cmake install target to /usr/local/fdo...


From: fdo-users-bounces at lists.osgeo.org [mailto:fdo-users-bounces at lists.osgeo.org] On Behalf Of kernel_panic
Sent: Friday, October 09, 2009 5:27 PM
To: FDO Users Mail List
Subject: Re: [fdo-users] FDO Compile error (libxalan-c)


BTW, there is an fdo folder under /usr/local/fdo-3.5.0/ but its totally empty, shoudlnt be there fdo libraries?

I noticed that today, while building mapguide oem (having more problems there, but a couple of them are already listed, Im working on the last one but my back es KILLING me :S), because when I was reading the documentation and it said that fdo should have been installed on said path by default (/usr/local/fdo/), I checked there and there was nothing, I remembered that you previously mentioned that path, re-read our post and confirmed that the path was correct, but there was nothing there... what happened? :p

Whoops :p:p sorry  for that,   I ran make install again, andd found that the install path wasnt /usr/local/fdo-3.5.0/lib but instead it was /usr/local/lib/fdo-3.5.0/lib/

This is different that the installed location mentioned on the official mapguide documentation, from the install pdf:

  "MapGuide requires the FDO include files and FDO libraries. If you have installed FDO in a location
other than the default of /usr/local/fdo-3.2.3, you must use the --with-fdo-include and --with-fdo-lib
configuration options."

So, since I never defined the location where I wanted to install fdo (therefore, it was the default) I think that either the default install loaction gets moved back to /usr/local/fdo... (where mapguide will automatically look for, if not you have to pass the --with-fdo-include/lib arguments) or mapguide should look into this path (/usr/local/lib/fdo-3.5.0/) and the official documentation should reflect this change.

I guess the simplest solution to this problem would be to just switch the default installation path to mapguide's default, but thats just my two cents, so devs will decide whats simplest and whats better.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osgeo.org/pipermail/fdo-users/attachments/20091009/cc10b265/attachment-0001.html

More information about the fdo-users mailing list