[fdo-users] RE: Trouble connecting Mapguide to Postgis.

Orest Halustchak orest.halustchak at autodesk.com
Tue Sep 22 09:08:17 EDT 2009

Hi Remco,

In addition to libq.dll, there are a number of other dll's from the postgresql bin that you can try to copy into the fdo bin directory.

-          comerr32.dll

-          gssapi32.dll

-          k5sprt32.dll

-          krb5_32.dll

-          libeay32.dll

-          libiconv-2.dll

-          libintl-8.dll

-          libpq.dll

I have not tried postgres 8.4 yet, but I have used postgis 1.3.6 / postgres 8.3.7.


From: fdo-users-bounces at lists.osgeo.org [mailto:fdo-users-bounces at lists.osgeo.org] On Behalf Of Remco Houtkamp
Sent: Tuesday, September 22, 2009 2:46 AM
To: fdo-users at lists.osgeo.org
Subject: [fdo-users] Trouble connecting Mapguide to Postgis.

Hi list,

Somebody from the mapguide lijst told me about this list so I just subscribed. I 'm new to this game and an newbie, but learned a lot the last couple of months.

I finally managed to build the following setup:
Mapguide 2.1
Mapguide Maestro
Postgresql 8.4
Postgis 1.4

I've filled the database (postgresql) with data from open street map with osm2pgsql. I can connect from Udig to postgis and from Quantum Gis (1.3 !!! 1.0 included with osgeo4w is not working). So my postgis setups works.

In mapguide maestro I go through the following steps:
Create a new resource>data connection
OSGEO FDO Provider for Postgis
Database: osm  (is visible in Udig)
server: I tried localhost http://localhost/ http://<>
Port: 5432
Tried all three credentials but think it must be Specified Credentials with user postgres and my secret password ;)
Press test connection and then the following error appears:
De externe server heeft een fout geretourneerd: (559) MgFdoException.: An exception occurred in FDO component. Unable to load the FDO Provider: Kan opgegeven module niet vinden. (some of this is Dutch... for cannot find the module)

Somebody told me to test the fdo with depends.exe. This way we found out that libpq.dll is missing. After installing " a version of libpq.dll" I was able to run the the test connection. It returned no errors and I save the connection. After this I need a layer to connect to the data. Unfortunately I ge the following error:
De externe server heeft een fout geretourneerd: (559) MgFdoException.: (dutch for the external server returned an error)
An exception occurred in FDO component.
Unable to load the FDO Provider: (null)

The errorlog tells me:
<2009-09-18T10:40:23>                3508             Administrator
Error: An exception occurred in FDO component.
Unable to load the FDO Provider: (null)
- MgFeatureServiceHandler.ProcessOperation line 83 file
- MgOpTestFeatureSourceConnection.Execute line 100 file
- MgFdoConnectionManager.Open line 262 file

It looks like the problem lies within the libpq.dll file. Anybody a thought on how to solve this problem...

Thanks in advance, Remco  (The Netherlands)

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osgeo.org/pipermail/fdo-users/attachments/20090922/3b06415c/attachment.html

More information about the fdo-users mailing list