[fdo-users] Re: OGR Oracle connection problem

Greg Boone greg.boone at autodesk.com
Mon Aug 22 10:09:23 EDT 2011

I have seen posts that tell users to create such links to 0.9.8, but I don't know if that would cause the subsequent errors or not.

From: fdo-users-bounces at lists.osgeo.org [mailto:fdo-users-bounces at lists.osgeo.org] On Behalf Of Jan Malysiak
Sent: Monday, August 22, 2011 9:59 AM
To: FDO Users Mail List
Subject: [fdo-users] Re: OGR Oracle connection problem

Hi Greg, thanks for your reply,

Sure, I checked required libraries with ldd for libOGRProvider-3.4.0.so<http://libOGRProvider-3.4.0.so>, two of them were missing, as I remember those were libssl.so.6 and libcrypto.so.6. I made symbolic links to libssl.so.0.9.8 and libcrypto.so.0.9.8 respectively. Could this be the cause of the error?

Best regards,
Jan Małysiak
W dniu 22 sierpnia 2011 14:23 użytkownik Jan Małysiak <j.malysiak at hotmail.com<mailto:j.malysiak at hotmail.com>> napisał:

I would like to connect MapGuide OpenSource to Oracle Spatial database, I use Ubuntu and I've already learned that KingOracle Provider does not work on Linux, so now I attempt to make a connection using OSGeo FDO Provider for OGR. When I test connection in MapGuide Maestro I get "The remote server returned an error: (559) MgFdoException.: An exception occurred in FDO component.". For more details, I looked at error log and that's what I read:

<2011-08-22T14:08:14>     -1388410000    MapGuide Maestro v2.1.4.5245    Administrator
 Error: An exception occurred in FDO component.
        Connect failed:
  - MgFeatureServiceHandler.ProcessOperation() line 83 file FeatureServiceHandler.cpp
  - MgOpTestFeatureSourceConnection.Execute() line 100 file OpTestFeatureSourceConnection.cpp
  - MgFdoConnectionManager.Open() line 893 file FdoConnectionManager.cpp

I've searched a lot for similar problems, but I couldn't find any working solution. I've tried multiple various configurations of connection parameters, I've tried also adding Oracle client path to LD_LIBRARY_PATH, but still all my attempts were unsuccessful.

I use:
MapGuide Open Source 2.1.0
FDO 3.4.0
MapGuide Maestro 2.1.4
Ubuntu 10.10
Oracle Instant Client

Thank you for any help.

Best regards,
Jan Małysiak

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osgeo.org/pipermail/fdo-users/attachments/20110822/08e62336/attachment-0001.html

More information about the fdo-users mailing list