[FOSS-GPS] Can't get Ambiguity Validation Ratio to move

Danny Miller dannym at austin.rr.com
Mon Jun 20 04:07:31 EDT 2011

I'm new to RTK.  I have a pair of LEA-6T GPS units, one active Sarantel 
SL-1206 quadrafiliar helix ant.  There were supposed to be two of those 
but the second one was DOA so I'm making do with an active patch antenna 
for the second.  I don't have an antenna file for either of them.  I'm 
using 2.4.1.

I have UBX RXM-RAW and RXM-SFRB reading out of both of them at 5Hz 
(tried this at 1Hz too).  I can get a fix out of either one of them.  In 
Kinematic mode of RTKNavi, I get a position, but the "ratio factor of 
ambiguity validation" factor is stuck at 0.0.  I waited like an hour and 
it was still at 0.

In the data window of RTKNavi, I noticed the Lat/long/height of Base is 
not listed with real numbers (90deg 0m).  This isn't right- that GPS has 
a fine solution in NMEA.  Both Base and Rover are showing strong 
(~45dbHz) signal bars in all colors.

I looked under Solution 1 and Solution 2 and both have valid, similar 

I looked under errors and saw:
eight "outlier rejected" per sample period (5Hz)
one "no double-differenced residuals" message

I tried switching the COM ports for Base and Rover, effectively 
switching which unit was which (neither is moving right now).  Nothing 
changed, the "Base" unit channel still has no Lat/long/height and 
ambiguity validation is still 0.  That is, the problem is not tied to 
the GPS hardware unit.

I tried disabling the Rover in RTKnavi.  There's still no solution under 
the Lat/Long/Height of Base.  The signal strength bars all turn gray.

I tried the mkl version (I have an i7).  It didn't change anything.
I tried 2.4.0 rtknavi.  In that one, I can't get a rover solution to 
show up at all, it's blank on the main window and rtkplot shows nothing.

Any ideas?


More information about the FOSS-GPS mailing list