[Gdal-dev] Problem with gdalwarp on Win XP

naumov at buffalo.edu naumov at buffalo.edu
Mon Mar 21 16:31:30 EST 2005

Dear Frank and developers,

I am having a strange problem with gdalwarp on Win XP and 2000. I run 
gdalwarp and get a windows error ("gdalwarp.exe has encountered an 
error and needs to close"), however the output from gdalwarp seems fine.

Since the output seems ok, I would not mind this so much, except that I 
need to run gdalwarp in a script to process many images, and having to 
click on "Dont send" several hundred times is very annoying.

Has anyone seen this? Here is my system info (detailed problem 
description below)

Win XP(+SP2) or Win 2000
FWTools0.9.6 for windows (binary)


I add GCPs to an image (saving to another image) with gdal_translate, 
then run gdalwarp on it. An example input image for gdalwarp looks like:

> gdalinfo temp_gtif.tif
Driver: GTiff/GeoTIFF
Size is 320, 240
Coordinate System is `'
GCP Projection = GEOGCS["WGS 84",DATUM["WGS_1984",SPHEROID
GCP[  0]: Id=1, Info=
          (0,0) -> (363002,713814,0)
GCP[  1]: Id=2, Info=
          (320,0) -> (362876,714000,0)
GCP[  2]: Id=3, Info=
          (0,240) -> (363142,713908,0)
GCP[  3]: Id=4, Info=
          (320,240) -> (363016,714095,0)
GCP[  4]: Id=5, Info=
          (160,120) -> (363009,713954,0)
Corner Coordinates:
Upper Left  (    0.0,    0.0)
Lower Left  (    0.0,  240.0)
Upper Right (  320.0,    0.0)
Lower Right (  320.0,  240.0)
Center      (  160.0,  120.0)
Band 1 Block=256x256 Type=Byte, ColorInterp=Red
Band 2 Block=256x256 Type=Byte, ColorInterp=Green
Band 3 Block=256x256 Type=Byte, ColorInterp=Blue

When I run the following gdalwarp command:
> gdalwarp -of GTiff -tr 1 1 -rb -co "TFW=YES" -dstnodata 0 
temp_gtif.tif temp_gtif2.tif

gdalwarp shows progress:
Creating output file that is 266P x 281L.
:0...10...20...30...40...50...60...70...80...90...100 - done.

but I get a popup saying "gdalwarp.exe has encountered a problem and 
needs to close. ...". There is an option to report this to MS and 
review the technical info, which looks like a binary dump (sorry I am 
out of my league here), however there is no way to copy it (short of 
using multiple screen shots). There is also a file attached to the bug 
info, which begins like:
<?xml version="1.0" encoding="UTF-16"?>
    <MATCHING_FILE NAME="adrg.dll" SIZE="36864" CHECKSUM="0xDA394CD7" 

If you find it useful, I'd be glad to send the file, of course. 

   - it happens with the same particular input files (with about half 
of them), and not with others
   - it seems to depend on the input and output file names; if I tweek 
the names, for example to make them shorter, than gdalwarp goes through 
w/o any problem. Not sure, however if this will hold when I process a 
thousand images in batch mode...

The problem does not exist on Linux (FC2, GDAL 1.2.6 from source); 
unfortunately at work I am absolutely stuck with Win :-((

I would really appreciate any insight into this, as I need to crunch 
quite a few images.

Thank you,


More information about the Gdal-dev mailing list