[Gdal-dev] Error making GDAL CVS daily "snapshot"

Bill Thoen bthoen at gisnet.com
Thu Nov 30 16:29:06 EST 2006

Apparently lidn is a curl thing. I tried ./configure --without-curl, but
that didn't work. Then I tried removing $(CURL_LIB) from the LIBS list in
GDALmake.opt, and that didn't work because several other things wanted to
reference those libraries. SO I finally uninstalled curl, and probably broke
a bunch of other stuff in OpenOffice (sigh! 'yum remove' seems to be very
thorough) but then GDAL built just fine.

On Thu, Nov 30, 2006 at 02:01:36PM -0500, Frank Warmerdam wrote:
> Bill Thoen wrote:
> >I just tried to build the latest version of GDAL from the CVS daily
> >snapshot and got this error:
> >
> >[stuff clipped]...
> >g++: /usr/lib/libidn.so: No such file or directory
> >make[1]: *** [libgdal.la] Error 1
> >make[1]: Leaving directory `/home/bthoen/gdal-cvs-2006.11.30'
> >make: *** [check-lib] Error 2
> Bill,
> You might try editing GDALmake.opt and removing libidn (or -lidn) from the
> link library list.  I had never heard of it before, but a google search
> suggests:
>   http://www.gnu.org/software/libidn/
> I imagine it is a dependency of one of the things that gdal depends on,
> though I don't know why this would have changed from 1.3.2.
> Best regards,
> -----------------------------+--------------------------------------
> I set the clouds in motion - turn up   | Frank Warmerdam, 
> warmerdam at pobox.com
> light and sound - activate the windows | http://pobox.com/~warmerdam
> and watch the world go round - Rush    | President OSGeo, http://osgeo.org

More information about the Gdal-dev mailing list