[Gdal-dev] Opening E00 files

Craig Miller craig.miller at spatialminds.com
Tue Oct 31 14:37:08 EST 2006

Followup to my previous post.  In the file
gdal\ogr\ogrsf_frmts\generic\ogrregisterall.cpp there are several calls to
RegisterXYZ() each of which is nestled between a pair of #ifdef XYZ_ENABLED
#endif statements.  At the bottom of this file is a call to RegisterOGRE00()
that is commented out (no #define).  I've never tried it, but you might try
calling RegisterOGRE00 manually and/or uncomment this line if you want to
use OGRRegisterAll();.


-----Original Message-----
From: gdal-dev-bounces at lists.maptools.org
[mailto:gdal-dev-bounces at lists.maptools.org] On Behalf Of Devon Noonan
Sent: Tuesday, October 31, 2006 10:55 AM
To: gdal-dev at lists.maptools.org
Subject: [Gdal-dev] Opening E00 files

Here is my situation; I originally used the ogrinfo utility to see if there
was support for the E00 sections that I am looking for. It opened the file
(not a binary source but a single e00 file) and gave me the sections back.
Excellent, no problems here. Now I have integrated it in to my program and
tried to open a file, it continually tells me that the file could not be
opened. I used the RegisterOGRAVCBin() call to initialize the driver. When
the driver tries to open the file it throws the error. Do I need to call in
to the AVC library before or after I try to open the file?

Any help would be appreciated!

Devon Noonan

Gdal-dev mailing list
Gdal-dev at lists.maptools.org

More information about the Gdal-dev mailing list