[Gdal-dev] Re: ECW "ecwp protocol updated" error

Lennox Antoine lxnyce at gmail.com
Mon Mar 12 17:59:50 EDT 2007

I believe the problem was that I was using a simplified name. The
simplified name changed "ecwp://" into "ecwp:/" which causes an error
when trying to load the ecwp protocol.

Thanks for your time guys.


On 3/12/07, Lennox Antoine <lxnyce at gmail.com> wrote:
> Hi All,
> I am field testing a product currently, and a user came across the
> following error :
> "I am trying to view this ecw server file
> ecwp://mapserver.lib.uconn.edu/magic/images/adimg.37800.0000.1934.s12.Fairchild.1.ecw"
> "when I press the "catalog" button, I keep getting this notice " Your
> settings have been updated to support ecwp protocol and you need to
> restart the application for settings to
> take affect." I get this notice like 10 times, it just keeps popping up.
> Is this an ECW integration problem, or more of an ECW SDK problem (in
> which case I will have to try contacting them)?
> I  looked into it and found similar issues here :
> From GlobalMappers webpage, I found this quote :
> "If you get an error message indicating that your settings have been
> updated to support the ECWP protocol whenever you try to load an ECW
> layer from the web you need to download and install the latest ECW
> ActiveX plugin from
> http://demo.ermapper.com/ecwplugins/DownloadIEPlugin.htm."
> I also found an Italian site which had the same problem using FWTools :
> http://translate.google.com/translate?u=http%3A%2F%2Fwww.bike-board.net%2Fcommunity%2Fforum%2Fshowthread.php%3Ft%3D35134%26page%3D27&langpair=it%7Cen&hl=en&ie=UTF8
> Interestingly enough, GDAL command line tools from fwtools work fine
> with the ecwp protocol. I grabbed the lib, header and dll's from there
> and made a thumbnail of the image above and it worked. I copied
> gdal_translate into a new command line application and used the same
> command, but I got the warning message.
> The user also mentions that installing the ActiveX control gets rid of
> the warning message, but the image still doesn't load.
> -Lennox

More information about the Gdal-dev mailing list