[gdal-dev] ComputeStatistics/GetHistogram errors

Christiaan Janssen cjanssen at iavo-rs.com
Thu Aug 14 09:09:58 EDT 2008

I wonder if anyone else is experiencing problems with the ComputeStatistics/GetHistogram functions. I'm running the latest build off the cvs trunk with the ERMapper ECW SDK linked in. Whenever I try to call the GetHistogram function (256 bins, 0-255 range) after running a ComputeStatistics on a JPEG2000 file I get an invalid access exception. If I run GetHistogram with identical inputs without calling ComputeStatistics at any time previous, the function runs and finishes with no problems. I tried tracking the error down but stopped at ReadLineBIL function in the ERMapper SDK. My guess is some state variable, most likely in the ERMapper SDK, is getting messed up during the ComputeStatistics function call (I'm not sure if any other functions would cause the same result, this is the only thing I've tried so far). If anyone can help it would be greatly appreciated.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osgeo.org/pipermail/gdal-dev/attachments/20080814/4f06ea7b/attachment-0001.html

More information about the gdal-dev mailing list