[gdal-dev] ComputeStatistics/GetHistogram errors

Frank Warmerdam warmerdam at pobox.com
Thu Aug 14 09:33:27 EDT 2008


I have had intermittent problems with heavy random access to
ECW datasets, presumably due to problems in some versions
of the ECW SDK.

I don't have any useful suggestions.

Best regards,

On Thu, Aug 14, 2008 at 9:09 AM, Christiaan Janssen
<cjanssen at iavo-rs.com> wrote:
> I wonder if anyone else is experiencing problems with the
> ComputeStatistics/GetHistogram functions. I'm running the latest build off
> the cvs trunk with the ERMapper ECW SDK linked in. Whenever I try to call
> the GetHistogram function (256 bins, 0-255 range) after running a
> ComputeStatistics on a JPEG2000 file I get an invalid access exception. If I
> run GetHistogram with identical inputs without calling ComputeStatistics at
> any time previous, the function runs and finishes with no problems. I tried
> tracking the error down but stopped at ReadLineBIL function in the ERMapper
> SDK. My guess is some state variable, most likely in the ERMapper SDK, is
> getting messed up during the ComputeStatistics function call (I'm not sure
> if any other functions would cause the same result, this is the only thing
> I've tried so far). If anyone can help it would be greatly appreciated.
> Christiaan
> _______________________________________________
> gdal-dev mailing list
> gdal-dev at lists.osgeo.org
> http://lists.osgeo.org/mailman/listinfo/gdal-dev

I set the clouds in motion - turn up | Frank Warmerdam, warmerdam at pobox.com
light and sound - activate the windows | http://pobox.com/~warmerdam
and watch the world go round - Rush | Geospatial Programmer for Rent

More information about the gdal-dev mailing list