[gdal-dev] Segmentation fault using gdal 1.4.4 and 1.5.2 on netcdf data

Frank Warmerdam warmerdam at pobox.com
Thu Aug 14 14:12:24 EDT 2008

On Thu, Aug 14, 2008 at 12:42 PM, Vishal Mehta <vishal.mehta at sei-us.org> wrote:

> 2. I compiled from source gdal1.5.2 from
> http://trac.osgeo.org/gdal/wiki/DownloadSource
> using the following configure
> ./configure --with-netcdf=/usr/lib --with-libtiff=yes --with-geotiff=yes --with-jpeg=/usr/lib --with-gif=/usr/lib --with-png=/ur/lib --with-pg=/usr/bin/pg_config --with-libgrass=yes
> make
> sudo make install
> and made sure the libgdal link was referring to the new one.
> I tried
> gdalinfo file.nc
> and again got 'segmentation fault'
> it works for other data types; only netcdf does not work (just like before with gdal1.4.4)


Have you tried with other netcdf files?  How big is "big"?   Perhaps
you are encounter a 2GB file size limit?

Best regards,
I set the clouds in motion - turn up | Frank Warmerdam, warmerdam at pobox.com
light and sound - activate the windows | http://pobox.com/~warmerdam
and watch the world go round - Rush | Geospatial Programmer for Rent

More information about the gdal-dev mailing list