[gdal-dev] Segmentation fault using gdal 1.4.4 and 1.5.2 on netcdf data

Vishal Mehta vishal.mehta at sei-us.org
Thu Aug 14 18:35:05 EDT 2008

Hi Frank,

I have tried with 2 netcdf files from different sites - same error 'segmentation fault'

the first was 60mb, the second was small !260kb.

does anyone in the list have this problem with gdal and netcdf data? earlier posts seemed to suggest a conflict between netcdf and hdf4, but i did not compile with hdf support so that shouldnt be a problem i thought..


From: fwarmerdam at gmail.com [fwarmerdam at gmail.com] On Behalf Of Frank Warmerdam [warmerdam at pobox.com]
Sent: Thursday, August 14, 2008 11:12 AM
To: Vishal Mehta
Cc: gdal-dev at lists.osgeo.org
Subject: Re: [gdal-dev] Segmentation fault using gdal 1.4.4 and 1.5.2 on netcdf data

On Thu, Aug 14, 2008 at 12:42 PM, Vishal Mehta <vishal.mehta at sei-us.org> wrote:

> 2. I compiled from source gdal1.5.2 from
> http://trac.osgeo.org/gdal/wiki/DownloadSource
> using the following configure
> ./configure --with-netcdf=/usr/lib --with-libtiff=yes --with-geotiff=yes --with-jpeg=/usr/lib --with-gif=/usr/lib --with-png=/ur/lib --with-pg=/usr/bin/pg_config --with-libgrass=yes
> make
> sudo make install
> and made sure the libgdal link was referring to the new one.
> I tried
> gdalinfo file.nc
> and again got 'segmentation fault'
> it works for other data types; only netcdf does not work (just like before with gdal1.4.4)


Have you tried with other netcdf files?  How big is "big"?   Perhaps
you are encounter a 2GB file size limit?

Best regards,
I set the clouds in motion - turn up | Frank Warmerdam, warmerdam at pobox.com
light and sound - activate the windows | http://pobox.com/~warmerdam
and watch the world go round - Rush | Geospatial Programmer for Rent

No virus found in this incoming message.
Checked by AVG - http://www.avg.com
Version: 8.0.138 / Virus Database: 270.6.3/1611 - Release Date: 8/14/2008 6:20 AM

More information about the gdal-dev mailing list