[gdal-dev] gdalwarp cutting off projected image

Scott Lewis scott.lewis at nsidc.org
Tue Dec 9 12:51:59 EST 2008


Thanks for the help.  I tried doing this, and ended up with the same 
image (even diff found them to be the same).  Here are the various 
commands I tried.  Maybe I'm just using the -wo option wrong.

gdalwarp -t_srs EPSG:4326 -wo SOURCE_EXTRA=1000 input.gtiff.tif 
gdalwarp -t_srs EPSG:4326 -wo "SOURCE_EXTRA=1000" input.gtiff.tif 
gdalwarp -t_srs EPSG:4326 -wo "SOURCE_EXTRA=1000 SAMPLE_GRID=YES 
SAMPLE_STEP=100" input.gtiff.tif output3.gtiff.tif

I'll continue to play with those options, though.  gdalwarp seems to not 
act any different (IE, it takes the same amount of time to process) with 
or without the -wo option, so I'm thinking I'm just not using the option 
correctly somehow.

Again, I appreciate your help!


Frank Warmerdam wrote:
> Scott Lewis wrote:
>> Hi,
>> I'm fairly new with GDAL, and have been working with a coworker who 
>> is a little more familiar with GDAL and gdalwarp, but we are both 
>> stumped by this particular issue.
>> I have a GeoTiff image that is in a north polar Lamber Azimuthal 
>> Equal Area (laea) projection.  I am trying to reproject it using 
>> gdalwarp to a cylindrical projection (like EPSG:4326).  I am using 
>> the following command:
>> gdalwarp -t_srs EPSG:4326 input.gtiff.tif output.gtiff.tif
>> The tool runs OK, but when I open output.gtiff.tif, the projection is 
>> "incomplete".  The parts that are there look correct, but it seems 
>> everything above about 50 degrees is cut off, like the 
>> input.gtiff.tif had a big circle around 50 degrees cut out before the 
>> reprojection was made.
>> I've tried looking at the options for gdalwarp, but can't seem to 
>> find anything that would help.
> Scott,
> There are various challenges in pole (or even dateline) spanning
> reprojection operations.  The options at:
> http://www.gdal.org/structGDALWarpOptions.html#0ed77f9917bb96c7a9aabd73d4d06e08 
> may be helpful.
> In particular, you might try specifying -wo SOURCE_EXTRA=1000 or some 
> similar
> large value on the gdalwarp commandline.  It is also possible that the
> SAMPLE_GRID=YES and SAMPLE_STEPS=100 options might help but generally if
> you have lots of RAM and a not-too-big input image specifying a large
> SOURCE_EXTRA value will resolve the issues.
> Best regards,

More information about the gdal-dev mailing list