[gdal-dev] Error in GDAL compiling with HDF4

Frank Warmerdam warmerdam at pobox.com
Thu Jul 30 11:52:11 EDT 2009

Limei Ran wrote:
> Hi Frank:
> I tried setting -fPIC based on the web site.  But, it failed as well.  I 
> checked config.log file and it has errors like:
> ==============
> /nas/uncch/depts/cep/emc/lran/mims/sa_06_2009/src/libs/HDF4.2r4/local/lib/libdf.a(cszip.o): 
> In function `HCIcszip_term':
> cszip.c:(.text+0x2ae): undefined reference to `SZ_BufftoBuffCompress'
> ===============
> It appears that szip is causing the problem.  I compiled HDF5 and HDF4 
> with szip-2.1.  After I compiled HDF4 without szip.  GDAL compiling worked.
> But, I am wondering whether I have to compile HDF5 and HDF4 with szip to 
> be used  in GDAL.


I normally avoid szip support as it seems rarely used and just extra
complexity.  However, if you are using static libraries for the HDF and
it depends on szip then somehow you need to introduce that into the GDAL

Hmm, looking in the configure code, it appears there is a case to try with
-lsz - I'm not sure why that does not kick in.

In any event, building without szip would be my suggestion.

Best regards,

I set the clouds in motion - turn up   | Frank Warmerdam, warmerdam at pobox.com
light and sound - activate the windows | http://pobox.com/~warmerdam
and watch the world go round - Rush    | Geospatial Programmer for Rent

More information about the gdal-dev mailing list