[gdal-dev] gdalinfo crashes or reports an error when reading a FITS file

Eric Davies eric at barrodale.com
Mon Nov 8 16:31:06 EST 2010

I've been trying to use the gdalinfo application to examine a number 
of FITS files that I've grabbed off the net. I've run into problems 
with both the precompiled/linked version of gdalinfo that comes with 
FWTOOLS.2.0.6, and with a copy I built myself from GDAL 1.7.2 source 
code and the cfitsio library. I'm running Linux (Fedora Core 13, 
Kernal 2.6) on a 32 bit Intel platform. It's not that I'm interested 
so much in the output of gdalinfo, but I wanted to verify that the 
underlying GDAL library could handle FITS before using it in my own 

Most FITS files I tried caused gdalinfo to die with a segmentation 
fault. For example, the following files caused segmentation faults:

The remaining files I tried caused more graceful failures, 
represented by the message below.
ERROR 1: FITS file /opt/data/fits/ngc6503.fits does not have 2 or 3 
gdalinfo failed - unable to open '/opt/data/fits/ngc6503.fits'.
File from http://fits.gsfc.nasa.gov/nrao_data/samples/cubes/ngc6503.fits

I was able to view these FITS file using SAOImage DS9. indicating 
that the files were not corrupt.

Has anybody tested GDAL against FITS files recently?

Thank you,

Eric Davies, M.Sc.
Senior Programmer Analyst
Barrodale Computing Services Ltd.
1095 McKenzie Ave., Suite 418
Victoria BC V8P 2L5

Tel: (250) 704-4428
Web: http://www.barrodale.com
Email: eric at barrodale.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osgeo.org/pipermail/gdal-dev/attachments/20101108/1c11fffe/attachment.html

More information about the gdal-dev mailing list