[gdal-dev] gdalinfo crashes or reports an error when reading a FITS file

Even Rouault even.rouault at mines-paris.org
Mon Nov 8 17:20:13 EST 2010


I've tried with Ubuntu 10.04 64 bit and a Win32 daily build and I have noticed 
the following behaviour in both cases :

1) gdalinfo file013.fits :
ERROR 1: Error while reading key 19 from FITS file file013.fits (203)
gdalinfo failed - unable to open 'file013.fits'.

--> I've looked a bit at that issue and just improved the driver (in trunk) so 
that it accepts that file now. See http://trac.osgeo.org/gdal/ticket/3822

2) gdalinfo m82opt.fits: works

3) gdalinfo ngc6503.fits :
ERROR 1: FITS file ngc6503.fits does not have 2 or 3 dimensions.
gdalinfo failed - unable to open 'ngc6503.fits'.

--> that one seems to be expected.

Perhaps you should try upgrading your cfitsio library ? And I'd note that 
FWTools 2.0.6 is getting pretty old now so you might run into bugs fixed in a 
more recent versions when using it.

Best regards,


Le lundi 08 novembre 2010 22:31:06, Eric Davies a écrit :
> I've been trying to use the gdalinfo application to examine a number
> of FITS files that I've grabbed off the net. I've run into problems
> with both the precompiled/linked version of gdalinfo that comes with
> FWTOOLS.2.0.6, and with a copy I built myself from GDAL 1.7.2 source
> code and the cfitsio library. I'm running Linux (Fedora Core 13,
> Kernal 2.6) on a 32 bit Intel platform. It's not that I'm interested
> so much in the output of gdalinfo, but I wanted to verify that the
> underlying GDAL library could handle FITS before using it in my own
> application.
> Most FITS files I tried caused gdalinfo to die with a segmentation
> fault. For example, the following files caused segmentation faults:
> http://fits.gsfc.nasa.gov/nrao_data/tests/ftt4b/file013.fits
> http://fits.gsfc.nasa.gov/nrao_data/samples/wcs/m82opt.fits
> The remaining files I tried caused more graceful failures,
> represented by the message below.
> ERROR 1: FITS file /opt/data/fits/ngc6503.fits does not have 2 or 3
> dimensions.
> gdalinfo failed - unable to open '/opt/data/fits/ngc6503.fits'.
> File from http://fits.gsfc.nasa.gov/nrao_data/samples/cubes/ngc6503.fits
> I was able to view these FITS file using SAOImage DS9. indicating
> that the files were not corrupt.
> Has anybody tested GDAL against FITS files recently?
> Thank you,
> Eric.
> **********************************************
> Eric Davies, M.Sc.
> Senior Programmer Analyst
> Barrodale Computing Services Ltd.
> 1095 McKenzie Ave., Suite 418
> Victoria BC V8P 2L5
> Canada
> Tel: (250) 704-4428
> Web: http://www.barrodale.com
> Email: eric at barrodale.com
> **********************************************

More information about the gdal-dev mailing list