[gdal-dev] S57 missing layers

Frank Warmerdam warmerdam at pobox.com
Tue May 3 10:45:07 EDT 2011

On 11-05-02 07:28 AM, Gabriel Breahna wrote:
> Hello,
> I have a S75 file, 1R5NK000.000, from this archive
> ftp://www.risserver.nl/ENC/Rotterdam_Amsterdam.zip.
> Using the command:
> ogrinfo.exe 1R5NK000.000
> I can see 31 layers.
> Using OpenCPN or SeeMyEnc I can see more layers in the same file:
> m_nsys
> wtwaxs
> feryrt
> comare
> dismar
> but seems ogrinfo despite of the fact all this layers are present into the
> s57objectclasses_iw.csv file, is not able to see them.


Unfortunately it seems the S57 driver does not autodetct the profile and
use the appropriate supporting files currently.  I found things worked
better if I specified the profile as "iw".

   ogrinfo 1R5NK000.000 --config S57_PROFILE iw

You can also set the S57_PROFILE configuration option as an environment

Note I still get a Generic class which suggests to me that my _iw
files are not completely up to date.

Best regards,
I set the clouds in motion - turn up   | Frank Warmerdam, warmerdam at pobox.com
light and sound - activate the windows | http://pobox.com/~warmerdam
and watch the world go round - Rush    | Geospatial Programmer for Rent

More information about the gdal-dev mailing list