[gdal-dev] S57 missing layers

Gabriel Breahna Gabriel.Breahna at euro.ro
Tue May 3 13:49:49 EDT 2011

Thanks Frank! I set "S57_PROFILE" to "iw" and now I can see all layers.

On 03.05.2011 17:45, Frank Warmerdam wrote:
> On 11-05-02 07:28 AM, Gabriel Breahna wrote:
>> Hello,
>> I have a S75 file, 1R5NK000.000, from this archive
>> ftp://www.risserver.nl/ENC/Rotterdam_Amsterdam.zip.
>> Using the command:
>> ogrinfo.exe 1R5NK000.000
>> I can see 31 layers.
>> Using OpenCPN or SeeMyEnc I can see more layers in the same file:
>> m_nsys
>> wtwaxs
>> feryrt
>> comare
>> dismar
>> but seems ogrinfo despite of the fact all this layers are present into the
>> s57objectclasses_iw.csv file, is not able to see them.
> Gabriel,
> Unfortunately it seems the S57 driver does not autodetct the profile and
> use the appropriate supporting files currently.  I found things worked
> better if I specified the profile as "iw".
>   ogrinfo 1R5NK000.000 --config S57_PROFILE iw
> You can also set the S57_PROFILE configuration option as an environment
> variable.
> Note I still get a Generic class which suggests to me that my _iw
> files are not completely up to date.
> Best regards,

More information about the gdal-dev mailing list