[gdal-dev] ogr2ogr reprojection, features are not transformed

Etienne Tourigny etourigny.dev at gmail.com
Tue Nov 15 17:25:49 EST 2011

Hi all,

I am working with data in the SAD69 Datum (EPSG:4618) from Brazil's
IBGE and when I convert any data to/from WGS84 (EPSG:4362) it appears
that there is absolutely no shift in the coordinates.

I understand that they are similar datums, but one would expect a visible shift.
The only changes are in the files are the .prj file which contain the

I use the following command:

$ ogr2ogr --debug on -t_srs EPSG:4326 LC_CIDADE_wgs84.shp LC_CIDADE.shp

OGR: OGROpen(LC_CIDADE.shp/0x1384170) succeeded as ESRI Shapefile.
OGRCT: Source: +proj=longlat +ellps=aust_SA +no_defs
OGRCT: Target: +proj=longlat +datum=WGS84 +no_defs
Shape: DBF Codepage = LDID/87 for LC_CIDADE_wgs84
Shape: Treating as encoding 'ISO-8859-1'.
Shape: 5806 features read on layer 'LC_CIDADE'.

I also tried the same command with an UTM projection, and again the
only thing that changes is the .prj file.  I have also tried it with
other shapefiles, with the same result.

Is this the expected behavior, or am I doing something wrong? I would
expect the geometries to be transformed, but apparently they are not.


More information about the gdal-dev mailing list