[gdal-dev] Strange behaviour of gdal_translate with ECW on linux (libecw 3.3)

Sylvain MAFFREN sylvain.maffren at crige-paca.org
Thu Feb 23 09:03:51 EST 2012


I try to convert RGB tiff file (300 Mo) into ECW ( libecw 3.3 and gdal 
1.8.1 that I have compiled) using this gdal_translate command, on a 
Debian Squeeze :  gdal_translate -of "ECW" -co LARGE_OK="YES" -co 
TARGET="90" -co DATUM="RGF93" -co PROJ="LMFRAN93" file_in.tif 
file_out.ecw, and I get strange results.

When I compare this results with ECW images that I get with the same 
command and the same source image with Windows binaries obtained here : 
/http://www.gisinternals.com/sdk//, MacOSX binaries obtained here : 
/http://www.kyngchaos.com/software: frameworks/ and translation with 
ErMapper with the same target, I note some differences between Linux 
results and other platforms results.

The result on Linux seems to be fuzzy, with poorer quality and a 
comparison with gdalinfo --mm --checksum confirm that fact (*images -- 
comparative tables downloadable here :**http://dl.free.fr/mkXpXahz3*- 
link "Télécharger ce fichier"). I also used this command with Linux 
binaries (FWTOOLS Linux 2.0.6) and the same differences are appearing. I 
try with Windows binaries 64 bits and the result is comparable to the 
linux one (Nevertheless it's perfect with 32 bits binaries).

I tried with "libecwj2-3.3-2006-09-06.zip" and 
"ImageCompressionSDKSourceCode3.3Setup_20070509.zip" source code, I have 
as well tried to apply all the patches I found on the web. It doesn't 
change anything. I also tried to compile libECW 3.3 on FreeBSD (which is 
quite same as MacOSX), without best results...

I posted this question on a French forum 
(http://www.forumsig.org/showthread.php?p=286890#post286890) and others 
users do the same observations.

With the decompression process (ECW to Tiff with GDAL_TRANSLATE), I have 
the same and good result on each platform.

It's seems that the only problem relies on the ECW compression on Linux, 
with 3.3 SDK version (I compiled examples in source tree of SDK 3.3 and 
I have done some tests: it seems that the ECW compression with SDK is 
bad too. That would mean this problem not appears with GDAL...?).

Does anybody know this problem ? If not, it would maybe be interesting 
to add this information in GDAL WIKI in order to prevent users of lib 
3.3 (I don't have an account to edit this page).

All ideas and remarks are welcome. I'm not C/C++ developer and it's very 
difficult for me to find an issue...

Best regards,


*Sylvain MAFFREN*

*Tél* : 04 42 90 71 22
*Fax* : 04 42 97 11 56

Domaine du Petit Arbois - Avenue Louis Philibert
BP 10019 - 13 545 Aix-en-Provence cedex 4
www.crige-paca.org <http://www.crige-paca.org/>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osgeo.org/pipermail/gdal-dev/attachments/20120223/835c6e28/attachment.html

More information about the gdal-dev mailing list