[gdal-dev] Strange effect in gdalwarp output

Monobakht nobakht.mo at gmail.com
Wed Jul 22 04:23:42 PDT 2015

This question was posted originally at 
but I did not get any helpful response. Here is the problem:

I am using gdalwarp in python to extract and re-project reflectance bands
from MODIS level 1B (MOD021km). The command that I am using is the

gdalwarp -of GTIFF -tps -t_srs EPSG:4326 -tr 0.01 0.01 -r bilinear

It converts the hdf subdataset without any problem but the output file seems
to have some sort of artifact, specially close to the edges. (See below)

I converted the same data using Modis Conversion Toolkit (MCTK) and it seems
to be much better. (Below)

I tried different resampling method and different output projection but
still the same results! Is there anyone having this issue with gdalwarp?

P.S. The data can be downloaded from this address:

View this message in context: http://osgeo-org.1560.x6.nabble.com/Strange-effect-in-gdalwarp-output-tp5216470.html
Sent from the GDAL - Dev mailing list archive at Nabble.com.

More information about the gdal-dev mailing list