[gdal-dev] "symbol(s) not found for architecture x86_64" when compiling GDAL 2.1.0 on Mac OS X

Michal Migurski mike at stamen.com
Sun Feb 12 10:52:59 PST 2017


I’ve recently switched to a new laptop, and I’m attempting to compile GDAL. I have libpng and jpeg in /urs/local via a fresh installation of Homebrew, and I am attempting to follow instructions for minimal drivers. This has worked without incident for me in the past, but I’m running into a problem I’ve not seen before.

What I’m doing:

env CPLUS_INCLUDE_PATH=/usr/local/include LIBRARY_PATH=/usr/local/lib ./configure --prefix=/Users/migurski/Sites/OpenAddresses-Machine/venv3-machine --with-threads --with-ogr --with-geos --without-libtool --with-libz=internal --with-libtiff=internal --with-geotiff=internal --without-gif --without-pg --without-grass --without-libgrass --without-cfitsio --without-pcraster --without-netcdf --without-png --without-jpeg --without-gif --without-ogdi --without-fme --without-hdf4 --without-hdf5 --without-jasper --without-ecw --without-kakadu --without-mrsid --without-jp2mrsid --without-bsb --without-grib --without-mysql --without-ingres --without-xerces --without-expat --without-odbc --without-curl --without-sqlite3 --without-dwgdirect --without-panorama --without-idb --without-sde --without-perl --without-php --without-ruby --without-python --without-ogpython --with-hide-internal-symbols

env CPLUS_INCLUDE_PATH=/usr/local/include LIBRARY_PATH=/usr/local/lib make

What I’m seeing:

ld: symbol(s) not found for architecture x86_64
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make[1]: *** [/Users/migurski/Sites/OpenAddresses-Machine/src/gdal-2.1.0/libgdal.dylib] Error 1
make: *** [check-lib] Error 2

Here’s a complete error output: http://dpaste.com/2RA08CZ

My environment:

Darwin Thinkfluence.local 16.3.0 Darwin Kernel Version 16.3.0: Thu Nov 17 20:23:58 PST 2016; root:xnu-3789.31.2~1/RELEASE_X86_64 x86_64

Configured with: --prefix=/Applications/Xcode.app/Contents/Developer/usr --with-gxx-include-dir=/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.12.sdk/usr/include/c++/4.2.1
Apple LLVM version 8.0.0 (clang-800.0.42.1)
Target: x86_64-apple-darwin16.3.0
Thread model: posix
InstalledDir: /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin

I tried all of this without the *_PATH variables in the environment, but found that the Homebrew libraries in /usr/local were not being found. Now they seem to be wrong, for some reason.

Thanks in advance for any helpful pointers!


michal migurski- contact info and pgp key:
sf/ca            http://mike.teczno.com/contact.html

More information about the gdal-dev mailing list