[gdal-dev] TypeError Wrong number or type of arguments for overloaded function 'CoordinateTransformation_TransformPoint'.

Paul Harwood runette at gmail.com
Wed Jun 16 09:01:15 PDT 2021

Yep - they should be fine (it is what I do) as long as none of the pip
packages install gdal or proj - which may work but may also cause problems.

As per the conda docs - you should try to install the conda packages into
the env BEFORE the pip packages - so you should probably start with a new
clean conda env, add the conda-forge packages and then add the pip packages.

I have occasionally had some problems between conda packages and GLOBAL pip
packages - since I think the later can override the conda environments. You
should not install any of your packages globally and only add them to the
virtual environment.

On Wed, 16 Jun 2021 at 16:51, zerovirus123 <briansia93 at gmail.com> wrote:

> Hi all,
>        So I created a new Conda environment, installed only gdal-3.3.0 from
> conda-forge, isolated the code snippet from my project and ran the code.
> The
> code executed without any issues. I then ran the test code in my old
> environment and it worked fine, but when I ran the whole project I got the
> TransformPoint error. It seems like an issue with my environment rather
> than
> gdal itself.
>       Would it be safe if I install gdal related libraries (fiona,
> geopandas, etc...) with conda-forge, and everything else with pip? Some
> packages can only be installed with pip...
> Thanks for the help. And by the way Jukka, how would I solve the database
> error?
> --
> Sent from: http://osgeo-org.1560.x6.nabble.com/GDAL-Dev-f3742093.html
> _______________________________________________
> gdal-dev mailing list
> gdal-dev at lists.osgeo.org
> https://lists.osgeo.org/mailman/listinfo/gdal-dev
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/gdal-dev/attachments/20210616/519933c0/attachment-0001.html>

More information about the gdal-dev mailing list